The wikis are now using the new authentication system.
If you did not migrate your account yet, visit https://idp-portal-info.suse.com/

GNOME/软件源

< GNOME(Redirected from GNOME/Repositories)
Jump to: navigation, search

注意! :本页面使用$current变量来描述当前的openSUSE发行版,在本文档发布时,$current=openSUSE11.1.

GNOME:Factory 或简称 G:F

这里是最新的GNOME版本构建的地方。

http://download.opensuse.org/repositories/GNOME:/Factory/

  • 这里同时提供Factory版以及$current版的软件包
  • 这意味着,当您连接到这个软件源时,您可以将您的GNOME升级到比$current版的GNOME更高的版本。
  • 一旦您激活(使用)了这个软件源,您必须使用 zypper dup 命令来接收更新后的GNOME

GNOME:Contrib 或简称 G:C

这里是为Contrib(openSUSE额外的官方软件源)开发的软件包。这里包含了许多最新版本的程序。

http://download.opensuse.org/repositories/GNOME:/Contrib/

  • 这里同时提供Factory版以及$current版的软件包

GNOME:Backports:x.yy 或简称 G:B:x.yy ( x.yy = GNOME 版本号或 Factory)

这里提供从 G:S:x.yy 或G:F $current安装GNOME时需要的更新包。 参阅 GNOME/2.26 了解如何在GNOME2.26使用这个软件源。

http://download.opensuse.org/repositories/GNOME:/Backports:/

  • 如果$current中某个软件包对构建GNOME来说太旧了时,它更新包会放在这里。同样,如果G:F中一个新的GNOME包不适合安装到$current,它的合适版放到这里.
    • 例如:在GNOME2.26有一个新版的gnome-power-manager.这个新版本需要DeviceKit 和DeviceKit-power (这两个都是新的软件包).这些软件包又需要新版的udev.因为我们不想在不必要时更新的关键的基础组件,所以,当GNOME更新到2.2.6版时,gnome-power-manager仍然被保留为2.24版.
  • 您应该和G:S:x.yy或 G:F一起使用这个软件源, 然后使用 zypper dup 来更新

GNOME:STABLE:x.yy 或简称 G:S:x.yy (x.yy为GNOME版本号)

这里是$current版的GNOME.参阅GNOME/2.26 了解如何在GNOME2.26中使用这个软件源.

http://download.opensuse.org/repositories/GNOME:/STABLE:/


  • $current版的GNOME的更新包位于这个软件源中.
  • 当Factory版成为新的下一个openSUSE发行版时,G:B中的软件包会被复制到这个软件源.
  • 如果您需要$current版的GNOME更新,您无须使用G:F或G:B
  • 一旦使用了,您需要使用 zypper up'

GNOME:UNSTABLE 或简写为 G:U

当openSUSE处于最新的 beta/RC时,GNOME:Factory被冻结,G:F不再接受更新包.

http://download.opensuse.org/repositories/GNOME:/UNSTABLE/

  • 当Factory被冻结时,这里提供GNOME下一个版本的更新
  • 当Factory重新开放,接受更新时,G:U中的软件包会被融合到G:F,为下一次openSUSE发行做准备.
  • 一旦使用,您需要 zypper dup命令

GNOME:Community

GNOME:Community是社区存放那些不能在openSUSE主(main)软件源获得的软件包.它现在不被支持,并且被GNOME:Contrib所取代。

请参阅policy, 了解GNOME:Community包含的软件包